Nur noch weiße Seite nach Update

  • Hi alle zusammen,


    ich habe gestern via Paketserver das Update von Version 1.0.4 auf Version 1.1.1 gemacht.


    Ich wurde aufgefordert ioncube zu installieren. Habe die local Methode gewählt, alles ordnungsgemäß installiert und bumm: Keine Fehler, Keine Warnungen und kein TSI mehr :-(


    Der ion wizard sagte alles ok für php7.2 und zend_extension läuft für cli.

    Somit habe ich wie empfohlen noch die wizard.php gelöscht. Apache2 neu gestartet und cache geleert.


    Nun wenn ich tsi aufrufe habe ich einfach nur eine leere seite ohne inhalt die in null komma nichts geladen wird.


    Woran kann das liegen?


    P.S.: Zur Kontrolle meine phpinfo.php


    Grüße

    Michael (Micha)

  • Interessant wären eher die Errorlogs des Webservers/Apache und PHP. Es klingt danach, dass der Server bei der Ausführung der Skripte ein Problem hat (deshalb sind auch die TSI Errorlogs leer, da es garnicht ausgeführt wurde) Aber im error_log sollte des Rätsels Lösung zu finden sein :)

    Viele Grüße aus Stuttgart / Kind Regards from Stuttgart
    Alex


    ..:: THIS IS OUR HOUSE - and our Housemusic ! :love:<3 ::..




  • Daniel

    Hat das Label Rückmeldung ausstehend hinzugefügt
  • Die Lösung funktioniert leider auch nicht.


    Die apache2 logs und php logs haben keine relevante ausgabe bezüglich php oder zugriffsfehler auf den tsi ordner. es fehlen auch keine abhängigkeiten. Es scheinen beim update mehrere Dateien beschädigt worden zu seien. öffne ich diese nun zb die config.php ist ein teil der datei kryptisch.


    Also na dem Entfernen ALLER Installationsdateien inklusive des config ordners, entpacken des 1.1.1.zip inhaltes in diesen Ordner und neu Installation mit den selben Zugangsdaten aber anderem prefix in der selben DB funktioniert alles wieder mit aktueller Version und alle Daten sind noch vorhanden. So zu sagen wurde nur der Front-End des TSI neu aufgespielt.


    Aber wieso und warum dieser Fehler zu stande kam bleibt mir ein Rätsel.

  • Der Teil deiner Config ist codiert. Hmnnn...

    Der manuelle Upload hat auch nicht geklappt (zur Sicherheit den FTP Übertragungsmodus auf binär stellen).

    Im Errorlog steht nichts von corrupt file oder File not found?

    Viele Grüße aus Stuttgart / Kind Regards from Stuttgart
    Alex


    ..:: THIS IS OUR HOUSE - and our Housemusic ! :love:<3 ::..




  • die config.php

    Welche config.php? Meinst du die default-config.php?


    Es scheinen beim update mehrere Dateien beschädigt worden zu seien

    Hast du nicht den Hinweis beachtet, der in den Ankündigungen zum Update dabei stand?

    Wichtige Update-Informationen / TSI Main System 1.1.0 STABLE + Module am 16.09.2018


    Es steht zumindest


    ...1.1.1 erfolgreich installiert...


    ...1.1.1.zip entfernt...


    als letzte zeilen und auch sonst keine errors. Nur Updated files.

    Und dann hat er dich aufgeforder ionCube zu installieren, richtig? Das bedeutet du hattest nicht schon vorher alles vorbereitet so wie ausdrücklich empfohlen? Das ist kein Wunder das dabei Dateien beschädigt wurden, denn er spielt ja während dem Update die verschlüsselten Dateien ein mit denen das System dann ja nichts mehr anfangen kann wenn du nicht schon ionCube eingerichtet hast..


    Die Lösung funktioniert leider auch nicht.

    Wie genau bist du vorgegangen? Hast du die Zip-Datei hochgeladen und auf dem Server entpackt oder hast du die Dateien mittels FTP einzeln überschrieben?

  • Nein, rein gar nichts.

    Der Apache selbst hat in der access log den http1.1 500 ausgegeben und seit mehreren Tagen keine Fehler bezüglich irgendeiner datei des TSI in den error.logs stehen. nur andere kleinigkeiten die mit dem tsi nichs zu tun haben sondern mit dem eqdkp core und iredadmin diensten.


    Soll ich mal die "defekten" Dateien anhängen?

  • Ich habe einfach in meiner 1.0.40 Installation das Update des 1.1.1. paketes angestoßen. und danach wurde ich zur ioncrube installation aufgefordern, richtig.


    Was mich nur gewundert hat. Ich habe mit rsync -av --delete ein backup eingespielt von vorheriger woche und selbst das lud dann nicht mehr.

  • Soll ich mal die "defekten" Dateien anhängen?

    Wenn du mir sagst ob du ionCube vor dem Update richtig installiert hattest, dann kann ich dir sagen ob das was bring, anonsten währe das sinnlos, denn er hat wahrscheinlich noch viel mehr Dateien zerschossen. Ich versuche dir zu erklären warum. Beim Updateprozess werden deine alten Dateien überschrieben, die neuen Dateien werden davor aber eingelesen. Wenn du jetzt vor dem Update nicht schon ionCube richtig installiert hattest dann werden die Dateien auch nicht richtig eingelesen und in der neuen Datei stehen dann diese cryptischen Zeichen wie du so schön sagst. Es tut mir sehr leid, aber allem anschein hilft da wirklich nur eine Neuinstallation. Ich weiß nicht ob ich die Hinweise zum Update auf 1.1.0 noch deutlicher hätte platzieren können, aber es liegt höchstwarscheinlich daran das du nicht auf das Upate vorbereitet warst, so leid es mir tut :(

  • Also kurz zusammen gefasst, nehme ich da die Schuld gerne voll auf mich^^


    Ich habe bis vor kurzem alles auf apache2 + mysql5.7 + php7.0 gefahren. Nun habe ich alles am Front-End (Forum, etc.) auf aktuellsten Stand gebracht und habe php auf 7.2 angehoben.

    Dadurch dachte ich: "hey, tsi kann ich ab php7.1 ja auf 1.1.0 heben. Mittlerweile ist ja sogar 1.1.1 draußen, geil, anklicken". Nach kurzer Ladezeit kam dann dieser mehr total fremder loader wizard und ich habe mich dann durch die routine gewurschtelt. Successfully installed and all works fine.

    F5 gedrückt --> Weiße Seite --> ?????


    Also das hab ich einfach total verkackt, weil ich mich vorher überhaupt nicht um die Vorraussetzungen gekümmert bzw belesen habe ob es da noch irgendwelche Zwischenschritte gibt oder gab. Da hat einfach der Update-Wahn durchgeschlagen.

    Die Neuisntallation war keine große Sache. WIe gesagt, alle Daten noch da. Ich musste die Routine nur bis zum SUper Admin Account erstellen neu durchlaufen und gut wars.


    Und mal ehrlich. Gerade solche Probleme mit Analyse, Hass, Verzweiflung und einem YES, ICH HABS! am Ende. Ist es wert.

  • Manchmal passiert sowas, ich kenne das selbst, vor lauter Updates ertappe ich mich selbst auch oft einfach Sachen zu überfliegen weils einfach manchmal soviel zum lesen ist :D Wenn jetzt alles gut ist, du wieder glücklich bist dann sind wir es auch.. Danke für deine Gedult und die Mithilfe :thumbup:

  • Daniel

    Hat das Label von Rückmeldung ausstehend auf Problem gelöst geändert
  • Bitte, Danke. Das einzige was mich eben nur hat auflaufen lassen war eben, dass es keinerlei Fehlerausgaben irgendwo gab. Der ioncubeloader tut was er soll und entschlüsselt die dateien welche vorher ja falsch kodiert wurden. php kann mit dem mist dann nichts anfangen und stellt sie einfach nicht dar als würde in der index.php nur <?php ?> stehen. Der Browser denkt sich dann: Hey das war ja easy^^


    Ja ich bin soweit wieder happy und Bedanke mich für die Hilfe und die Denkanstöße inklusive Lösung.

    Ich helfe auch gerne wo ich nur kann in Bereichen wie Server, Administration, Web, Backend, ach eigentlich in allem. Was ich bis dahin nicht weis, weis ich danach um so besser^^


    Einen schönen Tag noch an alle und macht weiter so.